Atlassian Confluence 7.5.x < 7.8.3 Arbitrary File Read

medium Web Application Scanning Plugin ID 112862
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Atlassian Confluence 7.5.x < 7.8.3 Arbitrary File Read

Description

According to its self-reported version number, the Atlassian Confluence application running on the remote host is prior to 6.13.18, 6.14.x < 7.4.6 or 7.5.x < 7.8.3. It is, therefore, affected by an incorrect path access check vulnerability allowing unauthenticated remote attackers to read arbitrary files within WEB-INF and META-INF directories.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Atlassian Confluence version 7.8.3 or later.

See Also

https://jira.atlassian.com/browse/CONFSERVER-60469

Plugin Details

Severity: Medium

ID: 112862

Type: remote

Published: 7/5/2021

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3

Risk Factor: Medium

Base Score: 5.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:atlassian:confluence:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 11/10/2020

Vulnerability Publication Date: 11/10/2020

Reference Information

CVE: CVE-2020-29448