Joomla! 3.x < 3.9.26 Multiple Vulnerabilities

medium Web Application Scanning Plugin ID 112743
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


Joomla! 3.x < 3.9.26 Multiple Vulnerabilities


According to its self-reported version, the instance of Joomla! running on the remote web server is 3.x prior to 3.9.26. It is, therefore, affected by multiple vulnerabilities.

- Inadequate escaping allowed Cross-Site Scripting (XSS) using the logo parameter of the default templates on error pages. (CVE-2021-26030)

- Inadequate filters on module layout settings could lead to a local file inclusion. (CVE-2021-26031)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Update to Joomla! version 3.9.26 or latest.

See Also

Plugin Details

Severity: Medium

ID: 112743

Type: remote

Published: 4/15/2021

Updated: 10/7/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2021-26031


Risk Factor: Medium

Base Score: 5

Vector: AV:N/AC:L/Au:N/C:P/I:N/A:N


Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:joomla:joomla\!:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 4/14/2021

Vulnerability Publication Date: 4/14/2021

Reference Information

CVE: CVE-2021-26030, CVE-2021-26031