PHP 7.4.x < 7.4.13 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 112670

Synopsis

PHP 7.4.x < 7.4.13 Multiple Vulnerabilities

Description

According to its self-reported version number, the version of PHP installed on the remote host is 7.3.x prior to 7.3.25 or 7.4.x prior to 7.4.13. It is, therefore, affected by multiple vulnerabilities as specified by the changelogs of the respective fixed releases.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to PHP version 7.4.13 or later.

See Also

https://www.php.net/ChangeLog-7.php#7.4.13

Plugin Details

Severity: Medium

ID: 112670

Type: remote

Published: 2020/12/08

Updated: 2020/12/08

Scan Template: api, scan, pci

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2020/11/26

Vulnerability Publication Date: 2020/11/26

Reference Information