TinyMCE < 4.9.7 Cross-Site Scripting

Medium Web Application Scanning Plugin ID 112655


TinyMCE < 4.9.7 Cross-Site Scripting


According to its self-reported version number, TinyMCE is prior to 4.9.7 or 5.x prior to 5.1.4. Therefore, it may be affected by a cross-site scripting vulnerability in the core parser, paste and visualchars plugins.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to TinyMCE version 4.9.7 or later.

See Also


Plugin Details

Severity: Medium

ID: 112655

Type: remote

Published: 2020/11/19

Updated: 2020/11/19

Scan Template: api, scan, pci

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:tiny:tinymce:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2020/08/10

Vulnerability Publication Date: 2020/08/10

Reference Information

CVE: CVE-2020-17480