WordPress 3.7.x < 3.7.35 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 112631


WordPress 3.7.x < 3.7.35 Multiple Vulnerabilities


According to its self-reported version number, the detected WordPress application is affected by multiple vulnerabilities :

- A deserialization vulnerability exists in Requests_Utility_FilteredIterator class.

- A cross-site scripting (XSS) vulnerability exists via global variables and post slugs.

- A denial of service vulnerability against the MySQL database.

- Two privilege escalation vulnerabilities in XML-RPC.

- An arbitrary file deletion vulnerability exists via a bypass of protected meta.

- A cross-site request forgery (CSRF) vulnerability exists when updating a background image.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Update to WordPress version 3.7.35 or latest.

See Also



Plugin Details

Severity: Medium

ID: 112631

Type: remote

Published: 2020/11/12

Updated: 2020/11/12

Scan Template: api, scan, pci

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2020/10/29

Vulnerability Publication Date: 2020/10/29

Reference Information