Apache Tomcat 10.0.0-M1 < 10.0.0-M8 Information Disclosure

medium Web Application Scanning Plugin ID 112627
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Apache Tomcat 10.0.0-M1 < 10.0.0-M8 Information Disclosure

Description

The version of Apache Tomcat installed on the remote host is 10.0.0-M1 to 10.0.0-M7, 9.0.0.M1 to 9.0.37 or 8.5.0 to 8.5.57. It is, therefore, affected by a vulnerability. If an HTTP/2 client exceeds the agreed maximum number of concurrent streams for a connection (in violation of the HTTP/2 protocol), it is possible that a subsequent request made on that connection could contain HTTP headers - including HTTP/2 pseudo headers - from a previous request rather than the intended headers. This can lead to users seeing responses for unexpected resources.

Note that the scanner has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 10.0.0-M8 or later.

See Also

http://tomcat.apache.org/security-10.html#Fixed_in_Apache_Tomcat_10.0.0-M8

Plugin Details

Severity: Medium

ID: 112627

Type: remote

Published: 10/27/2020

Updated: 10/7/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2020-13943

CVSS v2

Risk Factor: Medium

Base Score: 4

Vector: AV:N/AC:L/Au:S/C:P/I:N/A:N

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 10/12/2020

Vulnerability Publication Date: 10/12/2020

Reference Information

CVE: CVE-2020-13943