PHP 7.3.x < 7.3.21 Use After Free Vulnerability

low Web Application Scanning Plugin ID 112608



PHP 7.3.x < 7.3.21 Use After Free Vulnerability


According to its self-reported version number, the version of PHP running on the remote web server is 7.2.x prior to 7.2.33, 7.3.x prior to 7.3.21 or 7.4.x prior to 7.4.9. It is, therefore, affected by a use after free vulnerability in the phar_parse function due to mishandling of the actual_alias variable. An unauthenticated, remote attacker could exploit this issue by dereferencing a freed pointer which could lead to arbitrary code execution.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to PHP version 7.3.21 or later.

See Also

Plugin Details

Severity: Low

ID: 112608

Type: remote

Published: 10/9/2020

Updated: 10/26/2022

Scan Template: scan, pci, api

Risk Information


Risk Factor: Low

Base Score: 3.3

Vector: AV:L/AC:M/Au:N/C:P/I:N/A:P

CVSS Score Source: CVE-2020-7068


Risk Factor: Low

Base Score: 3.6

Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:L

CVSS Score Source: CVE-2020-7068

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 9/9/2020

Vulnerability Publication Date: 9/9/2020

Reference Information

CVE: CVE-2020-7068