Apache 2.4.x < 2.4.46 Multiple Vulnerabilities

critical Web Application Scanning Plugin ID 112580
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Apache 2.4.x < 2.4.46 Multiple Vulnerabilities

Description

According to its banner, the version of Apache running on the remote host is 2.4.x prior to 2.4.46. It is, therefore, affected by multiple vulnerabilities:

- mod_proxy_uwsgi info disclosure and possible remote code execution (CVE-2020-11984)

- When trace/debug was enabled for the HTTP/2 module and on certain traffic edge patterns, logging statements were made on the wrong connection, causing concurrent use of memory pools. Configuring the LogLevel of mod_http2 above info will mitigate this vulnerability for unpatched servers. (CVE-2020-11993)

- A specially crafted value for the Cache-Digest header in a HTTP/2 request would result in a crash when the server actually tries to HTTP/2 PUSH a resource afterwards. Configuring the HTTP/2 feature via H2Push off will mitigate this vulnerability for unpatched servers. (CVE-2020-9490)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache version 2.4.46 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.4.46

https://httpd.apache.org/security/vulnerabilities_24.html#2.4.44

Plugin Details

Severity: Critical

ID: 112580

Type: remote

Published: 9/9/2020

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS Score Source: CVE-2020-11984

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 8/7/2020

Vulnerability Publication Date: 8/7/2020

Reference Information

CVE: CVE-2020-9490, CVE-2020-11984, CVE-2020-11993

CWE: 444, 120

WASC: Buffer Overflow, HTTP Request Smuggling

OWASP: 2013-A9, 2017-A9, 2021-A4, 2021-A6

OWASP API: 2019-API7