Email Subscribers & Newsletters Plugin for WordPress < 4.5.1 Multiple Vulnerabilities

medium Web Application Scanning Plugin ID 112577
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Email Subscribers & Newsletters Plugin for WordPress < 4.5.1 Multiple Vulnerabilities

Description

The WordPress Email Subscribers & Newsletters Plugin installed on the remote host is affected by a Cross-site Request Forgery vulnerability in send_test_email() and an authenticated SQL injection vulnerability in es_newsletters_settings_callback().

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Email Subscribers & Newsletters Plugin for WordPress 4.5.1 or latest.

See Also

https://www.tenable.com/security/research/tra-2020-44-0

https://wordpress.org/plugins/email-subscribers/

Plugin Details

Severity: Medium

ID: 112577

Type: remote

Published: 8/31/2020

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: cpe:2.3:a:icegram:email_subscribers_\&_newsletters:4.4.8:*:*:*:*:wordpress:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 7/17/2020

Vulnerability Publication Date: 7/17/2020

Reference Information

CVE: CVE-2020-5767, CVE-2020-5768