ThinkPHP 5.0.x < 5.0.23 / 5.1.x < 5.1.31 Remote Code Execution

high Web Application Scanning Plugin ID 112564

Synopsis

ThinkPHP 5.0.x < 5.0.23 / 5.1.x < 5.1.31 Remote Code Execution

Description

A remote code execution vulnerability exists within multiple subsystems of ThinkPHP 5.0.x and 5.1.x. This potentially allows attackers to exploit multiple attack vectors on a ThinkPHP site, which could result in the site being completely compromised.

Note: This has been detected using an active check and should be remediated immediately.

Solution

Upgrade to ThinkPHP version 5.0.23 / 5.1.31 or later.

See Also

https://blog.thinkphp.cn/869075

https://github.com/nangge/noneCms/issues/21

http://www.thinkphp.cn/topic/60390.html

Plugin Details

Severity: High

ID: 112564

Type: remote

Published: 2/19/2019

Updated: 5/22/2020

Scan Template: api, scan, pci

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

Exploit Available: true

Patch Publication Date: 11/12/2018

Vulnerability Publication Date: 11/12/2018

Reference Information

CVE: CVE-2018-20062