Apache Tomcat 9.0.0.M1 < 9.0.37 Denial of Service

Medium Web Application Scanning Plugin ID 112549

Synopsis

Apache Tomcat 9.0.0.M1 < 9.0.37 Denial of Service

Description

The version of Apache Tomcat installed on the remote host is 10.0.0-M1 to 10.0.0-M6, 9.0.0.M1 to 9.0.36, 8.5.0 to 8.5.56 or 7.0.0 to 7.0.104. It is, therefore, affected by two denial of service vulnerabilities via WebSocket frame and HTTP/2 requests.

Note that the scanner has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 9.0.37 or later.

See Also

https://tomcat.apache.org/security-9.html#Fixed_in_Apache_Tomcat_9.0.37

Plugin Details

Severity: Medium

ID: 112549

Type: remote

Published: 2020/08/14

Updated: 2020/08/14

Scan Template: api, scan, pci

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:/a:apache:tomcat:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2020/07/05

Vulnerability Publication Date: 2020/07/05

Reference Information

CVE: CVE-2020-13934, CVE-2020-13935