Sitefinity < 6.0.4230.0 Multiple Vulnerabilities

High Web Application Scanning Plugin ID 112502

Synopsis

Sitefinity < 6.0.4230.0 Multiple Vulnerabilities

Description

The version of Sitefinity installed on the remote host is affected by multiple vulnerabilities :

- An XSS vulnerability in Telerik.ReportViewer affects versions 4.2 through 11.0 (CVE-2017-9140)

- An XSS vulnerability in?Identity Server affects versions 10.0 through 11.0 (CVE-2018-17053, CVE-2018-17054)

- An XSS vulnerability in Service Stack affects versions 10.2 through 11.0 (CVE-2018-17056)

- An arbitrary file upload vulnerability affects versions 4.0 through 11.0 (CVE-2018-17055)

- An arbitrary code execution in Dynamic Linq Parser affects versions 4.0 through 11.0

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Sitefinity version 6.0.4230.0 or later.

See Also

https://knowledgebase.progress.com/articles/Article/Security-Advisory-for-Resolving-Security-vulnerabilities-September-2018

https://insinuator.net/2018/10/vulnerabilities-in-sitefinity-wcms-a-success-story-of-a-responsible-disclosure-process/

https://www.veracode.com/blog/research/anatomy-cross-site-scripting-flaw-telerik-reporting-module

Plugin Details

Severity: High

ID: 112502

Type: remote

Published: 2018/10/31

Updated: 2019/01/31

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

Exploit Available: true

Patch Publication Date: 2018/09/25

Vulnerability Publication Date: 2018/09/25

Reference Information

CVE: CVE-2017-9140, CVE-2018-17053, CVE-2018-17054, CVE-2018-17055, CVE-2018-17056