Moment.js < 2.11.2 Regular Expression Denial of Service

high Web Application Scanning Plugin ID 112445

Synopsis

Moment.js < 2.11.2 Regular Expression Denial of Service

Description

According to its self-reported version number, Moment.js is prior to 2.11.2. Therefore, it may be affected by a regular expression denial of service vulnerability when arbitrary user input is passed into moment.duration().

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Moment.js version 2.11.2 or later.

See Also

https://www.npmjs.com/advisories/55

Plugin Details

Severity: High

ID: 112445

Type: remote

Published: 11/5/2018

Updated: 2/19/2020

Scan Template: api, scan, pci

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.8

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:C

CVSS v3.0

Base Score: 6.5

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Vulnerability Information

CPE: cpe:2.3:a:moment_project:moment:*:*:*:*:*:*:*:*

Patch Publication Date: 1/26/2016

Vulnerability Publication Date: 1/26/2016

Reference Information

CVE: CVE-2016-4055