Drupal 8.7.x < 8.7.14 Multiple Vulnerabilities

medium Web Application Scanning Plugin ID 112437
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


Drupal 8.7.x < 8.7.14 Multiple Vulnerabilities


According to its self-reported version, the instance of Drupal running on the remote web server is 7.0.x prior to 7.70, 8.7.x prior to 8.7.14 or 8.8.x prior to 8.8.6. It is, therefore, affected by multilple vulnerabilities :

- Two Cross-Site Scripting (XSS) vulnerabilities in jQuery (CVE-2020-11022 / CVE-2020-11023).

- An open redirect due to insufficient validation of the destination query parameter in the drupal_goto() function in Drupal 7 only (CVE-2020-13662).

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Update to Drupal version 8.7.14 or latest.

See Also




Plugin Details

Severity: Medium

ID: 112437

Type: remote

Published: 6/9/2020

Updated: 10/7/2021

Scan Template: scan, pci, api

Risk Information

CVSS Score Source: CVE-2020-13662


Risk Factor: Medium

Base Score: 5.8

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:N


Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 6/11/2020

Vulnerability Publication Date: 6/11/2020

Reference Information

CVE: CVE-2020-13662, CVE-2020-11022, CVE-2020-11023