jQuery 1.12.4 < 3.0.0 Cross-Site Scripting

medium Web Application Scanning Plugin ID 112435

Language:

Synopsis

jQuery 1.12.4 < 3.0.0 Cross-Site Scripting

Description

According to its self-reported version number, jQuery is at least 1.4.0 and prior to 1.12.0 or at least 1.12.4 and prior to 3.0.0-beta1. Therefore, it may be affected by a cross-site scripting vulnerability due to cross-domain ajax request performed without the dataType.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to jQuery version 3.0.0 or later.

See Also

https://github.com/jquery/jquery/issues/2432

https://github.com/jquery/jquery/pull/2588/commits/c254d308a7d3f1eac4d0b42837804cfffcba4bb2

Plugin Details

Severity: Medium

ID: 112435

Type: remote

Published: 11/5/2018

Updated: 10/7/2021

Scan Template: pci, scan

Risk Information

VPR

Risk Factor: Low

Score: 3.8

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS Score Source: CVE-2015-9251

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

CVSS Score Source: CVE-2015-9251

Vulnerability Information

CPE: cpe:2.3:a:jquery:jquery:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2018

Vulnerability Publication Date: 1/18/2018

Reference Information

CVE: CVE-2015-9251