jQuery 1.7.1 < 1.9.0 Cross-Site Scripting

medium Web Application Scanning Plugin ID 112432

Synopsis

jQuery 1.7.1 < 1.9.0 Cross-Site Scripting

Description

According to its self-reported version number, jQuery is at least 1.7.1 and prior to 1.9.0. Therefore, it may be affected by a cross-site scripting vulnerability due to jQuery(strInput).

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to jQuery version 1.9.0 or later.

See Also

https://github.com/jquery/jquery/commit/05531fc4080ae24070930d15ae0cea7ae056457d

Plugin Details

Severity: Medium

ID: 112432

Type: remote

Published: 11/5/2018

Updated: 10/7/2021

Scan Template: scan, pci

Risk Information

CVSS Score Source: CVE-2012-6708

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3

Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:jquery:jquery:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 1/18/2018

Vulnerability Publication Date: 1/18/2018

Reference Information

CVE: CVE-2012-6708