LearnDash Plugin for WordPress < 3.1.6 SQL Injection

critical Web Application Scanning Plugin ID 112386

Synopsis

LearnDash Plugin for WordPress < 3.1.6 SQL Injection

Description

The WordPress LearnDash Plugin installed on the remote host is affected by a SQL Injection in the 'learndash_get_course_groups' function in the ld-groups.php file due to improper validation of user-supplied input. An unauthenticated, remote attacker can exploit this to inject or manipulate SQL queries in the back-end database, resulting in the disclosure or manipulation of arbitrary data.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to LearnDash Plugin for WordPress 3.1.6 or latest.

See Also

https://research.checkpoint.com/2020/e-learning-platforms-getting-schooled-multiple-vulnerabilities-in-wordpress-most-popular-learning-management-system-plugins/

https://learndash.releasenotes.io/release/YBfaq-version-316

Plugin Details

Severity: Critical

ID: 112386

Type: remote

Published: 5/14/2020

Updated: 10/7/2021

Scan Template: scan, pci

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2020-6009

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2020-6009

Vulnerability Information

CPE: cpe:2.3:a:learndash:learndash:*:*:*:*:*:wordpress:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 4/1/2020

Vulnerability Publication Date: 4/1/2020

Reference Information

CVE: CVE-2020-6009