jQuery 1.2.0 < 3.5.0 Cross-Site Scripting

medium Web Application Scanning Plugin ID 112383
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


jQuery 1.2.0 < 3.5.0 Cross-Site Scripting


According to its self-reported version number, jQuery is at least 1.2.0 and prior to 3.5.0. Therefore, it may be affected by a cross-site scripting vulnerability via the regex operation in jQuery.htmlPrefilter.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to jQuery version 3.5.0 or later.

See Also



Plugin Details

Severity: Medium

ID: 112383

Type: remote

Published: 5/14/2020

Updated: 10/7/2021

Scan Template: scan, pci

Risk Information

CVSS Score Source: CVE-2020-11022


Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N


Risk Factor: Medium

Base Score: 6.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:jquery:jquery:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 4/29/2020

Vulnerability Publication Date: 4/29/2020

Reference Information

CVE: CVE-2020-11022, CVE-2020-11023