lighttpd < 1.4.36 mod_auth Arbitrary Log Entries Injection

Medium Web Application Scanning Plugin ID 112359

Synopsis

lighttpd < 1.4.36 mod_auth Arbitrary Log Entries Injection

Description

According to its banner, the version of lighttpd running on the remote host is prior to 1.4.36. It is, therefore, affected by mod_auth vulnerability that allows remote attackers to inject arbitrary log entries via a basic HTTP authentication string without a colon character, as demonstrated by a
string containing a NULL and new line character.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to lighttpd version 1.4.36 or later.

See Also

https://web.archive.org/web/20160907194723/http://jaanuskp.blogspot.com/2015/05/cve-2015-3200.html

https://www.lighttpd.net/2015/7/26/1.4.36/

Plugin Details

Severity: Medium

ID: 112359

Type: remote

Published: 2018/11/05

Updated: 2018/11/05

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Vulnerability Information

CPE: cpe:2.3:a:lighttpd:lighttpd:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2015/07/26

Vulnerability Publication Date: 2015/05/25

Reference Information

CVE: CVE-2015-3200

BID: 74813