lighttpd < 1.4.35 Multiple Vulnerabilities

High Web Application Scanning Plugin ID 112358

Synopsis

lighttpd < 1.4.35 Multiple Vulnerabilities

Description

According to its banner, the version of lighttpd running on the remote host is prior to 1.4.35. It is, therefore, affected by the following vulnerabilities :

- A SQL injection flaw exists in the 'mod_mysql_vhost' module where user input passed using the hostname is not properly sanitized. A remote attacker can exploit this to inject or manipulate SQL queries, resulting in the manipulation or disclosure of data. (CVE-2014-2323)

- A traverse outside of restricted path flaw exists with the 'mod_evhost' and 'mod_simple_vhost' modules where user input passed using the hostname is not properly sanitized. A remote attacker can exploit this to gain access to potentially sensitive data. (CVE-2014-2324)

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to lighttpd version 1.4.35 or later.

See Also

http://www.lighttpd.net/2014/3/12/1.4.35/

http://download.lighttpd.net/lighttpd/security/lighttpd_sa_2014_01.txt

http://download.lighttpd.net/lighttpd/security/lighttpd-1.4.34_fix_mysql_injection.patch

Plugin Details

Severity: High

ID: 112358

Type: remote

Published: 2018/11/05

Updated: 2018/11/05

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:2.3:a:lighttpd:lighttpd:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2014/03/12

Vulnerability Publication Date: 2014/03/12

Reference Information

CVE: CVE-2014-2323, CVE-2014-2324

BID: 66153, 66157