Apache Tomcat 7.0.41 < 7.0.79 Cache Poisoning Vulnerability

medium Web Application Scanning Plugin ID 112311
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

Apache Tomcat 7.0.41 < 7.0.79 Cache Poisoning Vulnerability

Description

The version of Apache Tomcat installed on the remote host is 7.0.41 or later but prior to 7.0.79. It is, therefore, affected by a flaw in the CORS filter where the HTTP Vary header is not properly added. This allows a remote attacker to conduct client-side and server-side cache poisoning attacks.

Note that the scanner has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.79 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.79

Plugin Details

Severity: Medium

ID: 112311

Type: remote

Published: 11/5/2018

Updated: 9/7/2021

Scan Template: api, scan, pci

Risk Information

CVSS Score Source: CVE-2017-7674

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:P/A:N

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 8/11/2017

Vulnerability Publication Date: 8/11/2017

Reference Information

CVE: CVE-2017-7674

CWE: 345

WASC: Insufficient Authentication

OWASP: 2010-A3, 2013-A2, 2013-A9, 2017-A2, 2017-A9, 2021-A6, 2021-A8

OWASP API: 2019-API7