Apache Tomcat 7.0.x < 7.0.81 Multiple Vulnerabilities

High Web Application Scanning Plugin ID 112310

Synopsis

Apache Tomcat 7.0.x < 7.0.81 Multiple Vulnerabilities

Description

The version of Apache Tomcat installed on the remote host is 7.0.x prior to 7.0.81. It is, therefore, affected by multiple vulnerabilities :

- An unspecified vulnerability when running on Windows with HTTP PUTs enabled (e.g. via setting the readonly initialization parameter of the Default to false) makes it possible to upload a JSP file to the server via a specially crafted request. This JSP could then be requested and any code it
contained would be executed by the server. (CVE-2017-12615, CVE-2017-12617)

- When using a VirtualDirContext it was possible to bypass security constraints and/or view the source code of JSPs for resources served by the VirtualDirContext using a specially crafted request. (CVE-2017-12616)

Note that the scanner has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.81 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.81

Plugin Details

Severity: High

ID: 112310

Type: remote

Published: 2018/11/05

Updated: 2018/11/05

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS v3.0

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Vulnerability Information

CPE: cpe:/a:apache:tomcat:*:*:*:*:*:*:*:*

Exploit Available: true

Patch Publication Date: 2017/08/16

Vulnerability Publication Date: 2017/09/19

Reference Information

CVE: CVE-2017-12615, CVE-2017-12616

BID: 100897, 100901

CWE: 434, 200

WASC: Improper Input Handling, Information Leakage

OWASP: 2010-A4, 2010-A6, 2013-A4, 2013-A5, 2013-A9, 2017-A5, 2017-A6, 2017-A9