Apache Tomcat 7.0.25 < 7.0.90 Multiple Vulnerabilities

critical Web Application Scanning Plugin ID 112305

Language:

Synopsis

Apache Tomcat 7.0.25 < 7.0.90 Multiple Vulnerabilities

Description

The version of Apache Tomcat installed on the remote host is at least 7.0.25 and prior to 7.0.90. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists in WebSocket client because host name verification is missing

- A flaw exists in CORS filter due to insecure defaults

Note that the scanner has not attempted to exploit these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 7.0.90 or later.

See Also

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.89

http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.90

Plugin Details

Severity: Critical

ID: 112305

Type: remote

Published: 11/5/2018

Updated: 10/7/2021

Scan Template: pci, api, scan

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

CVSS Score Source: CVE-2018-8014

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CVSS Score Source: CVE-2018-8014

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Exploit Ease: No known exploits are available

Patch Publication Date: 5/16/2018

Vulnerability Publication Date: 5/16/2018

Reference Information

CVE: CVE-2018-8014, CVE-2018-8034