Apache Tomcat 8.5.x < 8.5.16 Multiple Vulnerabilities

Medium Web Application Scanning Plugin ID 112301


Apache Tomcat 8.5.x < 8.5.16 Multiple Vulnerabilities


The version of Apache Tomcat installed on the remote host is 8.5.x prior to 8.5.16. It is, therefore, affected by multiple vulnerabilities :

- A flaw exists in the CORS filter because the HTTP Vary header was not properly added. This allows a remote attacker to conduct client-side and server-side cache poisoning attacks. (CVE-2017-7674)

- A flaw exists in the HTTP/2 implementation that bypasses a number of security checks that prevented directory traversal attacks. A remote attacker can exploit this to bypass security constraints. (CVE-2017-7675)

Note that the scanner has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 8.5.16 or later.

See Also


Plugin Details

Severity: Medium

ID: 112301

Type: remote

Published: 2018/11/05

Updated: 2018/11/05

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 7.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/a:apache:tomcat:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2017/06/26

Vulnerability Publication Date: 2017/08/10

Reference Information

CVE: CVE-2017-7674, CVE-2017-7675

BID: 100256, 100280

CWE: 345, 22

WASC: Insufficient Authentication, Path Traversal

OWASP: 2010-A3, 2010-A4, 2013-A2, 2013-A4, 2013-A9, 2017-A2, 2017-A5, 2017-A9