Apache Tomcat 8.5.x < 8.5.28 Security Constraint Weakness

Medium Web Application Scanning Plugin ID 112298

Synopsis

Apache Tomcat 8.5.x < 8.5.28 Security Constraint Weakness

Description

The version of Apache Tomcat installed on the remote host is 8.5.x prior to 8.5.28. It is, therefore, affected by security constraints flaws which could expose resources to unauthorized users.

Note that the scanner has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to Apache Tomcat version 8.5.28 or later.

See Also

http://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.5.28

Plugin Details

Severity: Medium

ID: 112298

Type: remote

Published: 2018/11/05

Updated: 2020/02/18

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

CVSS v3.0

Base Score: 5.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Vulnerability Information

CPE: cpe:/a:apache:tomcat:*:*:*:*:*:*:*:*

Exploit Available: false

Patch Publication Date: 2018/02/11

Vulnerability Publication Date: 2018/02/23

Reference Information

CVE: CVE-2018-1304, CVE-2018-1305

BID: 103144, 103170

CWE: 254, 284

WASC: Insufficient Authorization

OWASP: 2010-A4, 2010-A8, 2013-A4, 2013-A7, 2013-A9, 2017-A5, 2017-A9