WordPress < 4.7.2 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 9950
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote server is hosting an outdated installation of WordPress that is affected by multiple vulnerabilities.


Versions of WordPress prior to 4.7.2 are affected by multiple vulnerabilities :

- A flaw exists in the 'wp-admin/includes/class-wp-press-this.php' script that is triggered as the user interface for assigning taxonomy terms is exposed to users, who do not have permission to use it. This may allow an authenticated, remote attacker to gain unauthorized acces to sensitive information.
- A flaw exists that may allow carrying out an SQL injection attack. The issue is due to the 'wp-includes/class-wp-query.php' script not properly sanitizing input to post type names before using it in SQL queries. This may potentially allow a remote attacker to inject or manipulate SQL queries in the back-end database, allowing for the manipulation or disclosure of arbitrary data.
- A flaw exists that allows a cross-site scripting (XSS) attack. This flaw exists because the 'wp-admin/includes/class-wp-posts-list-table.php' script does not properly validated input to posts list table excerpts before returning it to users. This may allow a remote attacker to create a specially crafted request that will execute arbitrary script code in a user's browser session within the trust relationship between their browser and the server.
- A flaw exists in the '/wp-includes/rest-api/endpoints/class-wp-rest-posts-controller.php' script that is due to a failure to securely perform permission checks. This may allow a remote attacker to change the content of arbitrary posts or pages.


Upgrade to WordPress 4.7.2 or later.

See Also


Plugin Details

Severity: Medium

ID: 9950

Family: CGI

Published: 2/9/2017

Updated: 3/6/2019

Dependencies: 9035, 9036

Nessus ID: 96906

Risk Information


Risk Factor: Medium

Base Score: 5.1

Temporal Score: 4.2

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

Patch Publication Date: 1/26/2017

Vulnerability Publication Date: 1/26/2017

Reference Information

CVE: CVE-2017-5610, CVE-2017-5611, CVE-2017-5612

BID: 95816