WordPress < 4.7.2 Multiple Vulnerabilities

High Nessus Plugin ID 96906

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9


A PHP application running on the remote web server is affected by multiple vulnerabilities.


According to its self-reported version number, the WordPress application running on the remote web server is prior to 4.7.2.
It is, therefore, affected by multiple vulnerabilities :

- An information disclosure vulnerability exists in the class-wp-press-this.php script due to a failure to properly restrict the user interface for assigning taxonomy terms. An authenticated, remote attacker can exploit this to disclose sensitive information.

- A SQL injection (SQLi) vulnerability exists in the class-wp-query.php script due to a failure to sanitize input to post type names. An unauthenticated, remote attacker can exploit this to inject or manipulate SQL queries in the back-end database, resulting in the disclosure or manipulation of arbitrary data.

- A cross-site scripting (XSS) vulnerability exists in the class-wp-posts-list-table.php script due to improper validation of input to the posts list table. An unauthenticated, remote attacker can exploit this, via a specially crafted request, to execute arbitrary script code in a user's browser session. (CVE-2017-5612)

- A privilege escalation vulnerability exists in the REST API due to a failure to properly sanitize user-supplied input to the 'id' parameter when editing or deleting blog posts. An unauthenticated, remote attacker can exploit this issue to run arbitrary PHP code, inject content into blog posts, modify blog post attributes, or delete blog posts. (CVE-2017-1001000)

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to WordPress version 4.7.2 or later.

See Also



Plugin Details

Severity: High

ID: 96906

File Name: wordpress_4_7_2.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 2017/01/31

Updated: 2019/03/29

Dependencies: 18297

Configuration: Enable paranoid mode

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS Score Source: CVE-2017-5611

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Required KB Items: www/PHP, installed_sw/WordPress, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2017/01/26

Vulnerability Publication Date: 2017/01/26

Reference Information

CVE: CVE-2017-5610, CVE-2017-5611, CVE-2017-5612, CVE-2017-1001000

BID: 95816

EDB-ID: 41223, 41224, 41308