Flash Player < 11.2.202.643 / 23.0.0.205 RCE (APSB16-36)

critical Nessus Network Monitor Plugin ID 9801

Synopsis

The remote host is running an outdated version of Adobe Flash Player that is affected by a remote code execution (RCE) attack vector.

Description

Versions of Adobe Flash Player prior to 11.2.202.643 and 23.0.0.205 are unpatched, and therefore affected by a flaw that is triggered as user-supplied input is not properly validated. This may allow a context-dependent attacker to corrupt memory and potentially execute arbitrary code.

Solution

Upgrade to Adobe Flash Player version 23.0.0.205 or later. If 23.x cannot be obtained, version 11.2.202.643 has also been patched for this vulnerability.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb16-36.html

http://www.securityweek.com/adobe-patches-flash-vulnerability-used-targeted-attacks

Plugin Details

Severity: Critical

ID: 9801

Family: Web Clients

Published: 11/23/2016

Updated: 3/6/2019

Dependencies: 5158

Nessus ID: 92024

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.4

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*

Patch Publication Date: 10/26/2016

Vulnerability Publication Date: 10/26/2016

Reference Information

CVE: CVE-2016-4234

BID: 91725