Oracle MySQL 5.5.x < 5.5.51 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9609


The remote database server is vulnerable to multiple attack vectors.


The version of MySQL installed on the remote host is version 5.5.x prior to 5.5.51 and is affected by multiple issues :

- A flaw exists in the 'NAME_CONST()' function that is triggered during the handling of certain arguments. This may allow an authenticated attacker to crash the database. (OSVDB 142918)
- A flaw exists in a library used by MySQL. Specifically, the Henry Spencer regex Library (rxspencer) contains an overflow condition that is triggered as certain input is not properly validated. This may allow a context-dependent attacker to cause a buffer overflow, resulting in an unspecified impact that may include a denial of service in a process linked against the library or potentially allow the execution of arbitrary code. (OSVDB 143022)
- An unspecified flaw exists related to the DML subcomponent. This may allow an authenticated remote attacker to cause a denial of service. No further details have been provided by the vendor. (OSVDB 145980)


Upgrade to MySQL 5.5.51 or later.

See Also

Plugin Details

Severity: High

ID: 9609

File Name: 9609.prm

Family: Database

Published: 2016/09/30

Modified: 2016/11/04

Dependencies: 8914

Nessus ID: 93001, 93002

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 8.1

Temporal Score: 7.5


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2015/07/29

Vulnerability Publication Date: 2016/07/29

Reference Information

CVE: CVE-2016-5612

BID: 93622

OSVDB: 142918, 142922, 145980