MySQL 5.5.x < 5.5.51 Multiple Vulnerabilities

medium Nessus Plugin ID 93001

Synopsis

The remote database server is affected by multiple denial of service vulnerabilities.

Description

The version of MySQL running on the remote host is 5.5.x prior to 5.5.51. It is, therefore, affected by the multiple denial of service vulnerabilities:

- An unspecified flaw exists in the DML subcomponent that allows an authenticated, remote attacker to cause a denial of service condition. (CVE-2016-5612)

- A denial of service vulnerability exists in the NAME_CONST() function when handling certain unspecified arguments. An authenticated, remote attacker can exploit this to cause the server to exit.

Note that Nessus has not tested for these issues but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MySQL version 5.5.51 or later.

See Also

http://www.nessus.org/u?bac902d5

http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-51.html

http://www.nessus.org/u?453a538d

Plugin Details

Severity: Medium

ID: 93001

File Name: mysql_5_5_51_rpm.nasl

Version: 1.11

Type: local

Agent: unix

Family: Databases

Published: 8/17/2016

Updated: 6/3/2020

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS Score Source: CVE-2016-5612

CVSS v3

Risk Factor: Medium

Base Score: 6.5

Temporal Score: 5.7

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql, p-cpe:/a:amazon:linux:mysql, p-cpe:/a:centos:centos:mysql, p-cpe:/a:fedoraproject:fedora:mysql, p-cpe:/a:fermilab:scientific_linux:mysql, p-cpe:/a:novell:opensuse:mysql, p-cpe:/a:novell:suse_linux:mysql, p-cpe:/a:oracle:linux:mysql, p-cpe:/a:redhat:enterprise_linux:mysql

Required KB Items: Host/local_checks_enabled

Exploit Ease: No known exploits are available

Patch Publication Date: 7/29/2016

Vulnerability Publication Date: 7/29/2016

Reference Information

CVE: CVE-2016-5612