PostgreSQL 9.1.x < 9.1.23 / 9.2.x < 9.2.18 / 9.3.x < 9.3.14 / 9.4.x < 9.4.9 / 9.5.x < 9.5.4 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9552


The database running on the remote server is affected by multiple vulnerabilities.


The version of PostgreSQL installed on the remote host is 9.1.x prior or equal to 9.1.22, 9.2.x prior or equal to 9.2.17, 9.3.x prior or equal to 9.3.13, or 9.4.x prior or equal to 9.4.8, or 9.5.x prior or equal to 9.5.3 and is affected by multiple vulnerabilities :

- A flaw is triggered during the handling of specially crafted nest CASE expressions. This may allow an authenticated attacker to crash the database. (OSVDB 142811, OSVDB 142826)
- A flaw exists in 'pg_get_expr()' that is triggered during the handling of inconsistent values. This may allow an authenticated attacker to crash the database. (OSVDB 143018)
- An overflow condition exists in the 'to_number()' function. The issue is triggered as input strings are not properly validated. This may allow an authenticated attacker to cause a buffer overflow, resulting in a denial of service. (OSVDB 143019)


Upgrade to PostgreSQL 9.1.23 / 9.2.18 / 9.3.14 / 9.4.9 / 9.5.4, or later.

See Also

Plugin Details

Severity: High

ID: 9552

File Name: 9552.prm

Family: Database

Published: 2016/09/09

Modified: 2016/10/26

Dependencies: 8705

Nessus ID: 93050

Risk Information

Risk Factor: High


Base Score: 9

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 8.7

Temporal Score: 8.3


Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Patch Publication Date: 2016/08/11

Vulnerability Publication Date: 2016/08/11

Reference Information

CVE: CVE-2016-5423, CVE-2016-5424

BID: 92433

OSVDB: 142811, 142826, 143018, 143019