PostgreSQL 9.1.x < 9.1.23 / 9.2.x < 9.2.18 / 9.3.x < 9.3.14 / 9.4.x < 9.4.9 / 9.5.x < 9.5.4 Multiple Vulnerabilities

Critical Nessus Plugin ID 93050

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of PostgreSQL installed on the remote host is 9.1.x prior
to 9.1.23, 9.2.x prior to 9.2.18, 9.3.x prior to 9.3.14, 9.4.x prior
to 9.4.9, or 9.5.x prior to 9.5.4. It is, therefore, affected by the
following vulnerabilities :

- A denial of service vulnerability exists that allows an
authenticated, remote attacker to crash the database via
specially crafted nested CASE expressions.
(CVE-2016-5423)

- A flaw exists that is triggered during the handling of
database and role names with embedded special
characters. An unauthenticated, remote attacker can
exploit this to execute arbitrary code during
administrative operations such as pg_dumpall.
(CVE-2016-5424)

- A denial of service vulnerability exists in the
pg_get_expr() function that is triggered during the
handling of inconsistent values. An authenticated,
remote attacker can exploit this to crash the database.

- An overflow condition exists in the to_number() function
due to improper validation of user-supplied input. An
authenticated, remote attacker can exploit this to cause
a denial of service condition.

Solution

Upgrade to PostgreSQL version 9.1.23 / 9.2.18 / 9.3.14 / 9.4.9 / 9.5.4
or later.

See Also

https://www.postgresql.org/about/news/1688/

https://www.postgresql.org/docs/current/release-9-1-23.html

https://www.postgresql.org/docs/current/release-9-2-18.html

https://www.postgresql.org/docs/current/release-9-3-14.html

https://www.postgresql.org/docs/current/release-9-4-9.html

https://www.postgresql.org/docs/current/release-9-5-4.html

Plugin Details

Severity: Critical

ID: 93050

File Name: postgresql_20160811.nasl

Version: 1.11

Type: local

Family: Databases

Published: 2016/08/19

Modified: 2019/01/02

Dependencies: 63346

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:postgresql:postgresql

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2016/08/11

Vulnerability Publication Date: 2016/08/11

Reference Information

CVE: CVE-2016-5423, CVE-2016-5424

BID: 92433, 92435