PostgreSQL 9.1.x < 9.1.23 / 9.2.x < 9.2.18 / 9.3.x < 9.3.14 / 9.4.x < 9.4.9 / 9.5.x < 9.5.4 Multiple Vulnerabilities
Critical Nessus Plugin ID 93050
SynopsisThe remote database server is affected by multiple vulnerabilities.
DescriptionThe version of PostgreSQL installed on the remote host is 9.1.x prior
to 9.1.23, 9.2.x prior to 9.2.18, 9.3.x prior to 9.3.14, 9.4.x prior
to 9.4.9, or 9.5.x prior to 9.5.4. It is, therefore, affected by the
following vulnerabilities :
- A denial of service vulnerability exists that allows an
authenticated, remote attacker to crash the database via
specially crafted nested CASE expressions.
- A flaw exists that is triggered during the handling of
database and role names with embedded special
characters. An unauthenticated, remote attacker can
exploit this to execute arbitrary code during
administrative operations such as pg_dumpall.
- A denial of service vulnerability exists in the
pg_get_expr() function that is triggered during the
handling of inconsistent values. An authenticated,
remote attacker can exploit this to crash the database.
- An overflow condition exists in the to_number() function
due to improper validation of user-supplied input. An
authenticated, remote attacker can exploit this to cause
a denial of service condition.
SolutionUpgrade to PostgreSQL version 9.1.23 / 9.2.18 / 9.3.14 / 9.4.9 / 9.5.4