Apache HTTP Server 2.2.x < 2.2.32 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 9486


The remote web server is missing an Apache HTTP Server patch update.


The version of Apache HTTP Server 2.2 installed on the remote host is prior to 2.2.32 and is affected by multiple vulnerabilities :

- A remote proxy manipulation vulnerability exists related to missing protection against RFC 3875 section 4.1.18 namespace conflicts. The issue is triggered when handling requests containing 'Proxy' HTTP headers, as these may be stored in the HTTP_PROXY environment variable also commonly used to configure an outbound HTTP proxy for CGI applications. With a specially crafted request, a remote attacker can specify an arbitrary HTTP proxy server to be used by CGI applications relying on the HTTP_PROXY environment variable. (CVE-2016-5387)
- A flaw exists that is triggered when handling whitespace patterns in User-Agent headers. This may allow a remote attacker to use a specially crafted User-Agent header to cause the program to incorrectly handle sequences of requests, potentially interpreting responses incorrectly and polluting the cache, or disclosing content from one request to a second downstream user-agent. (CVE-2016-8743)


Upgrade to Apache HTTP Server version 2.2.32 or later.

See Also


Plugin Details

Severity: Medium

ID: 9486

Family: Web Servers

Published: 2016/08/26

Updated: 2019/03/06

Dependencies: 8945

Nessus ID: 96450

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 5.3

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Patch Publication Date: 2016/07/18

Vulnerability Publication Date: 2016/07/18

Reference Information

CVE: CVE-2016-5387, CVE-2016-8743

BID: 91816, 95077

IAVA: 2017-A-0010