Oracle MySQL 5.5.x < 5.5.49 / 5.6.x < 5.6.30 / 5.7.x < 5.7.12 Multiple Vulnerabilities

Critical Nessus Network Monitor Plugin ID 9482

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The version of MySQL installed on the remote host is 5.5.x prior to 5.5.49, 5.6.x prior to 5.6.30, or 5.7.x prior to 5.7.12. It is therefore affected by vulnerabilities in the following components :

- Data Manipulation Language
- Encryption
- Full-Text Search
- Federated
- InnoDB
- JSON
- Locking
- Log
- Optimizer
- Performance Schema
- Partition
- Pluggable Authentication
- Security Privileges

Solution

Upgrade to MySQL 5.7.12 later. If 5.7.x cannot be obtained, 5.6.30 and 5.5.49 have also been patched for these vulnerabilities.

See Also

http://www.oracle.com/technetwork/security-advisory/cpuapr2016v3-2985753.html#AppendixMSQL

http://www.oracle.com/technetwork/topics/security/cpuapr2016-2881694.html

Plugin Details

Severity: Critical

ID: 9482

File Name: 9482.prm

Family: Database

Published: 2016/08/26

Modified: 2016/09/16

Dependencies: 8914

Nessus ID: 90830, 90832, 90834, 91998

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Patch Publication Date: 2016/04/11

Vulnerability Publication Date: 2016/04/19

Reference Information

CVE: CVE-2016-0639, CVE-2016-0642, CVE-2016-0643, CVE-2016-0647, CVE-2016-0648, CVE-2016-0655, CVE-2016-0657, CVE-2016-0659, CVE-2016-0662, CVE-2016-0666, CVE-2016-0667, CVE-2016-3440, CVE-2016-3452, CVE-2016-5437

BID: 86445, 86457, 86484, 86493, 86495, 86506, 91910, 91917, 91999