OpenSSL 1.0.1 < 1.0.1o / 1.0.2 < 1.0.2c ASN.1 Encoder Negative Zero Value Handling RCE

Critical Nessus Network Monitor Plugin ID 9389

Synopsis

The remote web server is running an outdated instance of OpenSSL and that is affected by a buffer underflow vulnerability.

Description

According to its banner, the version of OpenSSL on the remote host is 1.0.1 prior to 1.0.1o, or 1.0.2 prior to 1.0.2c. It is therefore affected by an underflow condition in the ASN.1 encoder that is triggered when attempting to encode the value zero represented as a negative integer. This may allow a remote attacker to corrupt memory and potentially execute arbitrary code.

Solution

Upgrade OpenSSL to version 1.0.1o or 1.0.2c

See Also

https://www.openssl.org/news/secadv/20160503.txt

Plugin Details

Severity: Critical

ID: 9389

Family: Web Servers

Published: 2016/07/08

Modified: 2016/07/08

Dependencies: 5563

Nessus ID: 90888, 90889

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Patch Publication Date: 2015/06/11

Vulnerability Publication Date: 2016/05/03

Reference Information

CVE: CVE-2016-2108

BID: 89752