OpenSSL 1.0.2 < 1.0.2c ASN.1 Encoder Negative Zero Value Handling RCE

critical Nessus Plugin ID 90889
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote service is affected by a remote code execution vulnerability.

Description

According to its banner, the remote host is running a version of OpenSSL 1.0.2 prior to 1.0.2c. It is, therefore, affected by a remote code execution vulnerability in the ASN.1 encoder due to an underflow condition that occurs when attempting to encode the value zero represented as a negative integer. An unauthenticated, remote attacker can exploit this to corrupt memory, resulting in the execution of arbitrary code.

Solution

Upgrade to OpenSSL version 1.0.2c or later.

See Also

https://www.openssl.org/news/secadv/20160503.txt

https://www.openssl.org/news/cl102.txt

Plugin Details

Severity: Critical

ID: 90889

File Name: openssl_1_0_2c.nasl

Version: 1.8

Type: remote

Family: Web Servers

Published: 5/4/2016

Updated: 11/20/2019

Dependencies: openssl_version.nasl

Risk Information

CVSS Score Source: CVE-2016-2108

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.4

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Critical

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Ease: No known exploits are available

Patch Publication Date: 6/11/2015

Vulnerability Publication Date: 5/3/2016

Reference Information

CVE: CVE-2016-2108

BID: 89752