Samba 3.0.x versions 3.0.2 through 3.0.4 Buffer Overflow

Critical Nessus Network Monitor Plugin ID 9340

Synopsis

The remote Samba server is affected by a buffer overflow attack vector.

Description

According to its banner, the version of Samba running on the remote host is between 3.0.2 and 3.0.4, inclusive. An error exists in the base64 decoding functions, which can result in a buffer overflow.

Solution

Upgrade Samba to version 3.0.5 or later.

See Also

http://www.samba.org/samba/history/samba-3.0.5.html

http://www.samba.org/samba/security/CVE-2004-0600.html

Plugin Details

Severity: Critical

ID: 9340

Family: Samba

Published: 2016/06/09

Modified: 2016/06/09

Dependencies: 8740

Nessus ID: 17720

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2004/08/12

Vulnerability Publication Date: 2004/08/12

Reference Information

CVE: CVE-2004-0600

BID: 10780