Samba SWAT 3.0.2 - 3.0.4 HTTP Basic Auth base64 Buffer Overflow

critical Nessus Plugin ID 17720
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Samba server is affected by a buffer overflow vulnerability.

Description

According to its banner, the version of Samba running on the remote host is between 3.0.2 and 3.0.4, inclusive. An error exists in the base64 decoding functions, which can result in a buffer overflow.

Solution

Upgrade to version 3.0.5 or later.

See Also

http://www.samba.org/samba/history/samba-3.0.5.html

https://www.samba.org/samba/security/CVE-2004-0600.html

Plugin Details

Severity: Critical

ID: 17720

File Name: samba_3_0_5.nasl

Version: 1.9

Type: remote

Family: Misc.

Published: 11/18/2011

Updated: 11/15/2018

Dependencies: smb_nativelanman.nasl, swat_detect.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 7/20/2004

Vulnerability Publication Date: 4/28/2004

Reference Information

CVE: CVE-2004-0600

BID: 10780

EDB-ID: 364