Samba SWAT 3.0.2 - 3.0.4 HTTP Basic Auth base64 Buffer Overflow

critical Nessus Plugin ID 17720


The remote Samba server is affected by a buffer overflow vulnerability.


According to its banner, the version of Samba running on the remote host is between 3.0.2 and 3.0.4, inclusive. An error exists in the base64 decoding functions, which can result in a buffer overflow.


Upgrade to version 3.0.5 or later.

See Also

Plugin Details

Severity: Critical

ID: 17720

File Name: samba_3_0_5.nasl

Version: 1.10

Type: remote

Family: Misc.

Published: 11/18/2011

Updated: 4/11/2022

Configuration: Enable paranoid mode, Enable thorough checks

Risk Information


Risk Factor: Medium

Score: 6.7


Risk Factor: Critical

Base Score: 10

Temporal Score: 7.8

Vector: AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 7/20/2004

Vulnerability Publication Date: 4/28/2004

Reference Information

CVE: CVE-2004-0600

BID: 10780

EDB-ID: 364