Apple QuickTime < 7.7.7 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9304

Synopsis

The version of QuickTime on the remote machine is affected by multiple code execution vulnerabilities.

Description

Versions of QuickTime older than 7.7.7 are affected by the following vulnerabilities :

- A flaw is triggered as user-supplied input is not properly validated when handling specially crafted image data in an SGI file allowing a context-dependent attacker to potentially execute arbitrary code. (CVE-2015-3661)
- An out-of-bounds write flaw is triggered as user-supplied input is not properly validated when handling specially crafted image data in a GIF file allowing a context-dependent attacker to potentially execute arbitrary code. (CVE-2015-3662, CVE-2015-3663)
- An overflow condition is triggered as user-supplied input is not properly validated when handling alis atoms. With a specially crafted file, a context-dependent attacker can cause a stack-based buffer overflow, resulting in a denial of service or potentially allowing the execution of arbitrary code. (CVE-2015-3664)
- A use-after-free error is triggered when handling object properties in a specially crafted movie file allowing a context-dependent attacker to dereference already freed memory and potentially execute arbitrary code. (CVE-2015-3665)
- A flaw is triggered as user-supplied input is not properly validated when handling the code atom within the Media Information (minf) atom allowing a context-dependent attacker to use a specially crafted file to corrupt memory and potentially execute arbitrary code. (CVE-2015-3666)
- A use-after-free error in the 'QuickTimeMPEG4!0x147f0()' function is triggered when an out-of-bounds read error occurs during the handling of stbl ataoms. With a specially crafted movie (.MOV) file, a context-dependent attacker can dereference already freed memory and potentially execute arbitrary code. (CVE-2015-3667)
- A flaw is triggered as user-supplied input is not properly validated when handling a specially crafted track fragment's 'size' field inside a moof atom allowing a context-dependent attacker to cause a heap-based buffer overflow and potentially execute arbitrary code. (CVE-2015-3668)
- An overflow condition is triggered as user-supplied input is not properly validated. With a specially crafted SGI file, a context-dependent attacker can cause a heap-based buffer overflow, potentially allowing the execution of arbitrary code. (CVE-2015-3669)

Solution

Upgrade to QuickTime 7.7.7 or later.

See Also

https://support.apple.com/en-us/HT204947

Plugin Details

Severity: High

ID: 9304

Family: Web Clients

Published: 2016/04/20

Modified: 2018/09/16

Dependencies: 1735, 8314

Nessus ID: 84505

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 8.5

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apple:quicktime

Patch Publication Date: 2015/06/30

Vulnerability Publication Date: 2015/06/30

Reference Information

CVE: CVE-2015-3661, CVE-2015-3662, CVE-2015-3663, CVE-2015-3664, CVE-2015-3665, CVE-2015-3666, CVE-2015-3667, CVE-2015-3668, CVE-2015-3669

BID: 75493, 75497, 75498, 75499