Oracle MySQL 5.5.x < 5.5.44 / 5.6.x < 5.6.25 Multiple DoS

Medium Nessus Network Monitor Plugin ID 9256

Synopsis

The remote database server is vulnerable to multiple Denial of Service (DoS) attack vectors.

Description

The version of MySQL installed on the remote host is version 5.5.x prior to 5.5.44 or 5.6.x prior to 5.6.25 and is affected by unspecified flaws related to the following components :
- Server:Optimizer (CVE-2015-2643)
- Server:DML (CVE-2015-2648)
- Server:GIS (CVE-2015-2582)
- Server:I_S (CVE-2015-4752)

These flaws may allow an authenticated remote attacker to gain access to sensitive information. No further details have been provided by the vendor.

Solution

Upgrade to MySQL 5.6.25 or later. If 5.6.x cannot be obtained, version 5.5.44 is also patched for these issues.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.5/en/news-5-5-44.html

http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-25.html

Plugin Details

Severity: Medium

ID: 9256

Family: Database

Published: 2016/04/15

Modified: 2016/05/17

Dependencies: 8914

Nessus ID: 84767

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4

Temporal Score: 3.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 4.3

Temporal Score: 4.1

Vector: CVSS3#AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2015/07/14

Vulnerability Publication Date: 2015/07/14

Reference Information

CVE: CVE-2015-2643, CVE-2015-2648, CVE-2015-2582, CVE-2015-4752