Oracle MySQL 5.6.x < 5.6.28 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 9237

Synopsis

The remote database server is vulnerable to multiple attack vectors.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.28 and is affected by multiple issues :

- Multiple unspecified flaws exists in the Server:DML subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0503, CVE-2016-0504, CVE-2016-0595, CVE-2016-0596)
- An unspecified flaw exists in the Server:Options subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0505)
- An unspecified flaw exists in the Client subcomponent that allows a local attacker to gain elevated privileges. (CVE-2016-0546)
- Multiple unspecified flaws exist in the Server:Optimizer subcomponent that allow an authenticated, remote attacker to cause a denial of service. (CVE-2016-0597, CVE-2016-0598, CVE-2016-0611)
- An unspecified flaw exists in the Server:InnoDB subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0600, CVE-2016-0610)
- An unspecified flaw exists in the Server:Security:Encryption subcomponent that allows an authenticated, remote attacker to impact integrity. (CVE-2016-0606, CVE-2016-0609)
- An unspecified flaw exists in the Server:Replication subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0607)
- An unspecified flaw exists in the Server:UDF subcomponent that allows an authenticated, remote attacker to cause a denial of service. (CVE-2016-0608)
- A denial of service vulnerability exists due to repeatedly executing a prepared statement when the default database has been changed. An authenticated, remote attacker can exploit this to cause the server to exit.
- A denial of service vulnerability exists due to a flaw that is triggered when selecting DECIMAL values into user-defined variables. An authenticated, remote attacker can exploit this to cause the server to exit.
- A flaw exists in the Server:InnoDB subcomponent due to a failure to check for destination files with the same name when using the ALTER TABLE operation to convert a table to an InnoDB file-per-table tablespace. An authenticated, remote attacker can exploit this to cause a denial of service.
- A denial of service vulnerability exists that is triggered when updating views using ALL comparison operators on subqueries that select from indexed columns in the main table. An authenticated, remote attacker can exploit this to cause the server to exit, resulting in a denial of service condition.
- A flaw exists in the Server:InnoDB subcomponent that is triggered when handling ALTER TABLE operations. An authenticated, remote attacker can exploit this to cause a denial of service condition.
- A remote code execution vulnerability exists due to improper validation of user-supplied input to the 'strcpy()' and 'sprintf()' functions. An authenticated, remote attacker can exploit this to cause a buffer overflow, resulting in a denial of service condition or the execution of arbitrary code.
- A denial of service vulnerability exists due to a flaw that is triggered when selecting DECIMAL values into user-defined variables. An authenticated, remote attacker can exploit this to cause the server to exit.
- A denial of service vulnerability exists that is triggered when handling concurrent FLUSH PRIVILEGES and REVOKE or GRANT statements. An authenticated, remote attacker can exploit this to cause the server to exit by triggering an invalid memory access to proxy user information.
- A denial of service vulnerability exists that is triggered on the second execution of a prepared statement where an ORDER BY clause references a column position. An authenticated, remote attacker can exploit this to cause the server to exit.
- A denial of service vulnerability exists in the Server:Optimizer subcomponent due to accessing a stale pointer when handling filesorts for UPDATE statements. An authenticated, remote attacker can exploit this to cause the server to exit.

Solution

Upgrade to MySQL 5.6.28 or later.

See Also

http://dev.mysql.com/doc/relnotes/mysql/5.6/en/news-5-6-28.html

Plugin Details

Severity: High

ID: 9237

Family: Database

Published: 2016/04/15

Modified: 2018/09/16

Dependencies: 8914

Nessus ID: 87420

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.2

Temporal Score: 6.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 8.4

Temporal Score: 8

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2015/12/07

Vulnerability Publication Date: 2016/01/19

Reference Information

CVE: CVE-2016-0503, CVE-2016-0504, CVE-2016-0505, CVE-2016-0546, CVE-2016-0595, CVE-2016-0596, CVE-2016-0597, CVE-2016-0598, CVE-2016-0600, CVE-2016-0606, CVE-2016-0607, CVE-2016-0608, CVE-2016-0609, CVE-2016-0610, CVE-2016-0611