PHP 5.5.x < 5.5.32 / 5.6.x < 5.6.18 / 7.0.x < 7.0.3 Multiple Vulnerabilities

Critical Nessus Network Monitor Plugin ID 9093

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

Versions of PHP 5.5.x prior to 5.5.32, or 5.6.x prior to 5.6.18, or 7.0.x prior to 7.0.3 are vulnerable to the following issues :

- The Perl-Compatible Regular Expressions (PCRE) library is affected by multiple vulnerabilities related to the handling of regular expressions, subroutine calls, and binary files. A remote attacker can exploit these to cause a denial of service, obtain sensitive information, or have other unspecified impact.
- A flaw exists in file 'ext/standard/exec.c' in the 'escapeshellcmd()' and 'escapeshellarg()' functions due to the program truncating NULL bytes in strings. A remote attacker can exploit this to bypass restrictions.
- A flaw exists in file 'ext/standard/streamsfuncs.c' in the 'stream_get_meta_data()' function due to a failure to restrict writing user-supplied data to fields not already set. A remote attacker can exploit this to falsify the output of the function, resulting in the insertion of malicious metadata.
- A type confusion error exists in file 'ext/wddx/wddx.c' in the 'php_wddx_pop_element()' function when deserializing WDDX packets. A remote attacker can exploit this to have an unspecified impact.
- A flaw exists in file 'ext/phar/phar_object.c' in the 'PharFileInfo::getContent()' method due to the use of uninitialized memory causing improper validation of user-supplied input. A remote attacker can exploit this to corrupt memory, resulting in a denial of service or the execution of arbitrary code.
- A NULL pointer dereference flaw exists in file 'ext/phar/tar.c' in the 'phar_tar_setupmetadata()' function when parsing metadata from a crafted TAR file. A remote attacker can exploit this to cause a denial of service.
- An integer overflow condition exists in file 'ext/standard/iptc.c' in the 'iptcembed()' function due to improper validation of user-supplied input. A remote attacker can exploit this to cause a heap-based buffer overflow, resulting in a denial of service or the execution of arbitrary code.
- An overflow condition exists in file 'ext/phar/tar.c' in the 'phar_parse_tarfile()' function due to improper validation of user-supplied input when decompressing TAR files. A remote attacker can exploit this to cause a stack-based buffer overflow, resulting in a denial of service or the execution of arbitrary code.
- A use-after-free error exists in 'SPL_METHOD(SplObjectStorage)' in 'ext/spl/spl_observer.c'. The issue is triggered when handling unserialize calls. This may allow a remote attacker to dereference already freed memory and potentially execute arbitrary code.

Solution

Upgrade to PHP version 7.0.3 or later. If 7.x cannot be obtained, 5.6.18 and 5.5.32 are also patched for these vulnerabilities.

See Also

http://www.php.net/ChangeLog-5.php#5.5.32

http://www.php.net/ChangeLog-5.php#5.6.18

http://www.php.net/ChangeLog-7.php#7.0.3

Plugin Details

Severity: Critical

ID: 9093

Family: Web Servers

Published: 2016/02/25

Updated: 2019/03/06

Dependencies: 8682, 9243

Nessus ID: 88693, 88694, 88695

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 9.8

Temporal Score: 9.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2015/02/04

Vulnerability Publication Date: 2015/11/23

Reference Information

CVE: CVE-2015-8383, CVE-2015-8386, CVE-2015-8387, CVE-2015-8389, CVE-2015-8390, CVE-2015-8391, CVE-2015-8393, CVE-2015-8394

BID: 79810, 82990

IAVB: 2016-B-0025