CVE-2015-8387

high
New! CVE Severity Now Using CVSS v3

The calculated severity for CVEs has been updated to use CVSS v3 by default. CVEs that do not have a CVSS v3 score will fall back CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Description

PCRE before 8.38 mishandles (?123) subroutine calls and related subroutine calls, which allows remote attackers to cause a denial of service (integer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

References

http://lists.fedoraproject.org/pipermail/package-announce/2016-January/174931.html

http://vcs.pcre.org/pcre/code/trunk/ChangeLog?view=markup

http://www.openwall.com/lists/oss-security/2015/11/29/1

http://www.securityfocus.com/bid/82990

https://bto.bluecoat.com/security-advisory/sa128

https://h20566.www2.hpe.com/portal/site/hpsc/public/kb/docDisplay?docId=emr_na-c05240731

https://security.gentoo.org/glsa/201607-02

Details

Source: MITRE

Published: 2015-12-02

Updated: 2017-07-01

Type: CWE-189

Risk Information

CVSS v2

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Impact Score: 6.4

Exploitability Score: 10

Severity: HIGH

Vulnerable Software

Configuration 1

OR

cpe:2.3:a:pcre:perl_compatible_regular_expression_library:*:*:*:*:*:*:*:* versions up to 8.37 (inclusive)

Configuration 2

OR

cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:*

Tenable Plugins

View all (20 total)

IDNameProductFamilySeverity
126860EulerOS 2.0 SP2 : pcre (EulerOS-SA-2019-1733)NessusHuawei Local Security Checks
high
125102EulerOS Virtualization 3.0.1.0 : pcre (EulerOS-SA-2019-1558)NessusHuawei Local Security Checks
critical
98848PHP 7.0.x < 7.0.3 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
98807PHP 5.6.x < 5.6.18 Multiple VulnerabilitiesWeb Application ScanningComponent Vulnerability
high
110743EulerOS 2.0 SP3 : pcre (EulerOS-SA-2018-1167)NessusHuawei Local Security Checks
high
95915SUSE SLED12 / SLES12 Security Update : pcre (SUSE-SU-2016:3161-1)NessusSuSE Local Security Checks
critical
95754openSUSE Security Update : pcre (openSUSE-2016-1448)NessusSuSE Local Security Checks
critical
95534SUSE SLED12 / SLES12 Security Update : pcre (SUSE-SU-2016:2971-1)NessusSuSE Local Security Checks
critical
93343Tenable SecurityCenter < 5.3.0 Multiple Vulnerabilities (TNS-2016-04)NessusMisc.
medium
92667F5 Networks BIG-IP : Multiple PCRE vulnerabilities (K20225390)NessusF5 Networks Local Security Checks
high
91983GLSA-201607-02 : libpcre: Multiple VulnerabilitiesNessusGentoo Local Security Checks
critical
90306Ubuntu 12.04 LTS / 14.04 LTS / 15.10 : pcre3 vulnerabilities (USN-2943-1)NessusUbuntu Local Security Checks
critical
89647Fedora 23 : mingw-pcre-8.38-1.fc23 (2016-fd1199dbe2)NessusFedora Local Security Checks
critical
89641Fedora 22 : mingw-pcre-8.38-1.fc22 (2016-f59a8ff5d0)NessusFedora Local Security Checks
critical
89447Fedora 22 : pcre-8.38-1.fc22 (2015-eb896290d3)NessusFedora Local Security Checks
high
9093PHP 5.5.x < 5.5.32 / 5.6.x < 5.6.18 / 7.0.x < 7.0.3 Multiple VulnerabilitiesNessus Network MonitorWeb Servers
critical
88695PHP 7.0.x < 7.0.3 Multiple VulnerabilitiesNessusCGI abuses
critical
88694PHP 5.6.x < 5.6.18 Multiple VulnerabilitiesNessusCGI abuses
critical
88693PHP 5.5.x < 5.5.32 Multiple VulnerabilitiesNessusCGI abuses
critical
88671FreeBSD : php -- multiple vulnerabilities (85eb4e46-cf16-11e5-840f-485d605f4717)NessusFreeBSD Local Security Checks
critical