Oracle MySQL 5.6.x < 5.6.22 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 8920

Synopsis

The remote database server is missing a critical Oracle MySQL patch update.

Description

The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.22. It is, therefore, affected by errors in the following components :

- Server : Security : Encryption (CVE-2015-0411)
- Server : Replication (CVE-2015-0382)
- Server : Replication (CVE-2015-0381)
- Server : InnoDB : DML (CVE-2014-6568)
- Server : Security : Privileges : Foreign Key (CVE-2015-0374)
- Server : Optimizer (CVE-2015-0409)
- Server : Pluggable Auth (CVE-2015-0385)

Solution

Upgrade to MySQL 5.6.22 or later.

See Also

http://www.oracle.com/technetwork/topics/security/cpujan2015-1972971.html

Plugin Details

Severity: High

ID: 8920

Family: Database

Published: 2015/02/24

Modified: 2016/01/15

Dependencies: 8914

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Patch Publication Date: 2015/01/21

Vulnerability Publication Date: 2015/01/21

Reference Information

CVE: CVE-2014-6568, CVE-2015-0374, CVE-2015-0381, CVE-2015-0382, CVE-2015-0411, CVE-2015-0385, CVE-2015-0409

BID: 72191, 72200, 72210, 72214, 72223, 72227, 72229

IAVA: 2015-A-0015