Apache Tomcat 7.0.x < 7.0.59 / 8.0.x < 8.0.17 Security Manager Bypass

medium Nessus Network Monitor Plugin ID 8832
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Apache Tomcat server is affected by a security bypass vulnerability.

Description

According to its self-reported version number, the Apache Tomcat server listening on the remote host is 7.0.x prior to 7.0.59. It is, therefore, affected by a security bypass vulnerability due to a flaw that occurs when handling expression language. (CVE-2014-7810)
A remote attacker can exploit this, via a crafted web application, to bypass the security manager protection and execute arbitrary code.

Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Update to Apache Tomcat version 7.0.59 or 8.0.17 or later.

See Also

https://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.59

https://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.0.17

https://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.59,https://tomcat.apache.org/security-8.html#Fixed_in_Apache_Tomcat_8.0.17

Plugin Details

Severity: Medium

ID: 8832

Family: Web Servers

Published: 7/24/2015

Updated: 5/20/2019

Nessus ID: 83765

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 2/4/2015

Vulnerability Publication Date: 6/7/2015

Reference Information

CVE: CVE-2014-7810

BID: 74665