Apache Tomcat 8.0.x < 8.0.17 Security Manager Bypass

Medium Nessus Plugin ID 83765


The remote Apache Tomcat server is affected by a security bypass vulnerability.


According to its self-reported version number, the Apache Tomcat server listening on the remote host is 8.0.x prior to 8.0.17. It is, therefore, affected by a security bypass vulnerability due to a flaw that occurs when handling expression language. A remote attacker can exploit this, via a crafted web application, to bypass the security manager protection and execute arbitrary code.

Note that Nessus has not attempted to exploit this issue but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat version 8.0.17 or later.

See Also




Plugin Details

Severity: Medium

ID: 83765

File Name: tomcat_8_0_17.nasl

Version: $Revision: 1.7 $

Type: remote

Family: Web Servers

Published: 2015/05/21

Modified: 2018/01/24

Dependencies: 39446

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C


Base Score: 7.3

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Required KB Items: installed_sw/Apache Tomcat, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2015/01/16

Vulnerability Publication Date: 2014/05/14

Reference Information

CVE: CVE-2014-7810

BID: 74665

OSVDB: 122158