Apache Tomcat 6.0.x < 6.0.44 Multiple Vulnerabilities (FREAK)

Medium Nessus Network Monitor Plugin ID 8830

Synopsis

The remote Apache Tomcat server is affected by multiple vulnerabilities.

Description

According to its self-reported version number, the Apache Tomcat service listening on the remote host is 6.0.x prior to 6.0.44. It is, therefore, affected by multiple vulnerabilities:

- An error exists due to a failure to limit the size of discarded requests. A remote attacker can exploit this to exhaust available memory resources, resulting in a denial of service condition. (CVE-2014-0230)

- A NULL pointer dereference flaw exists when the SSLv3 option isn't enabled and an SSLv3 ClientHello is received. This allows a remote attacker, using an unexpected handshake, to crash the daemon, resulting in a denial of service. (CVE-2014-3569)

- The BIGNUM squaring (BN_sqr) implementation does not properly calculate the square of a BIGNUM value. This allows remote attackers to defeat cryptographic protection mechanisms. (CVE-2014-3570)

- A NULL pointer dereference flaw exists with dtls1_get_record() when handling DTLS messages. A remote attacker, using a specially crafted DTLS message, can cause a denial of service. (CVE-2014-3571)

- A flaw exists with ECDH handshakes when using an ECDSA certificate without a ServerKeyExchange message. This allows a remote attacker to trigger a loss of forward secrecy from the ciphersuite. (CVE-2014-3572)

- A malicious application can use expression language to bypass the internal Security Manager and execute code with elevated privileges. (CVE-2014-7810)

- A flaw exists when accepting non-DER variations of certificate signature algorithms and signature encodings due to a lack of enforcement of matches between signed and unsigned portions. A remote attacker, by including crafted data within a certificate's unsigned portion, can bypass fingerprint-based certificate-blacklist protection mechanisms. (CVE-2014-8275)

- A security feature bypass vulnerability, known as FREAK (Factoring attack on RSA-EXPORT Keys), exists due to the support of weak EXPORT_RSA cipher suites with keys less than or equal to 512 bits. A man-in-the-middle attacker may be able to downgrade the SSL/TLS connection to use EXPORT_RSA cipher suites which can be factored in a short amount of time, allowing the attacker to intercept and decrypt the traffic.

Solution

Upgrade to Apache Tomcat version 6.0.44 or later.

See Also

https://tomcat.apache.org/security-6.html#Fixed_in_Apache_Tomcat_6.0.44

http://tomcat.apache.org/tomcat-6.0-doc/changelog.html

https://seclists.org/bugtraq/2015/May/33

https://bugzilla.redhat.com/show_bug.cgi?id=1191200

http://svn.apache.org/viewvc?view=revision&revision=1603781

https://www.smacktls.com/#freak

Plugin Details

Severity: Medium

ID: 8830

Family: Web Servers

Published: 2015/07/24

Updated: 2019/05/20

Nessus ID: 83490

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apache:tomcat

Patch Publication Date: 2015/05/12

Vulnerability Publication Date: 2015/01/06

Reference Information

CVE: CVE-2014-0230

BID: 74475