Flash Player < 18.104.22.168 / 22.214.171.124 Multiple Vulnerabilities (APSB14-22)
High Nessus Network Monitor Plugin ID 8808
SynopsisThe remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.
DescriptionVersions of Adobe Flash player prior to 11.7.700.275 / 126.96.36.199 are outdated and thus unpatched for the following vulnerabilities :
- Multiple memory corruption issues due to improperly sanitized user-supplied input allow arbitrary code execution. (CVE-2014-0564, CVE-2014-0558)
- An integer overflow issue due to improperly sanitized user-supplied input that allows arbitrary code execution. (CVE-2014-0569)
- An arbitrary code execution vulnerability due to the handling of a dereferenced memory pointer. (CVE-2014-8439)
SolutionUpgrade to Adobe Flash Player version 188.8.131.52 or later. If 15.x cannot be obtained, 184.108.40.206 has also been patched for these vulnerabilities.