Flash Player for Mac <= 15.0.0.167 Multiple Vulnerabilities (APSB14-22)

Critical Nessus Plugin ID 78443

Synopsis

The remote Mac OS X host has a browser plugin that is affected by multiple vulnerabilities.

Description

According to its version, the installation of Adobe Flash Player installed on the remote Mac OS X host is equal or prior to 15.0.0.167.
It is, therefore, affected by the following vulnerabilities :

- Multiple memory corruption issues due to improperly sanitized user-supplied input allow arbitrary code execution. (CVE-2014-0564, CVE-2014-0558)

- An integer overflow issue due to improperly sanitized user-supplied input that allows arbitrary code execution. (CVE-2014-0569)

- An arbitrary code execution vulnerability due to the handling of a dereferenced memory pointer.
(CVE-2014-8439)

Solution

Upgrade to Adobe Flash Player version 15.0.0.189 or later.

Alternatively, Adobe has made version 13.0.0.250 available for those installations that cannot be upgraded to 15.x.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb14-22.html

http://www.nessus.org/u?0cb17c10

Plugin Details

Severity: Critical

ID: 78443

File Name: macosx_flash_player_15_0_0_189.nasl

Version: 1.14

Type: local

Agent: macosx

Published: 2014/10/15

Updated: 2019/11/25

Dependencies: 53914

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2014-8439

CVSS v2.0

Base Score: 10

Temporal Score: 8.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/10/14

Vulnerability Publication Date: 2014/10/14

Exploitable With

Core Impact

Metasploit (Adobe Flash Player casi32 Integer Overflow)

Reference Information

CVE: CVE-2014-0558, CVE-2014-0564, CVE-2014-0569, CVE-2014-8439

BID: 70437, 70441, 70442, 71289