Flash Player < 11.7.700.269 / 12.0.0.70 Multiple Vulnerabilities (APSB14-07)

High Nessus Network Monitor Plugin ID 8807

Synopsis

The remote host is running an outdated version of Adobe Flash Player for Internet Explorer that is affected by multiple vulnerabilities.

Description

Versions of Adobe Flash player prior to 11.7.700.275 / 13.0.0.182 are outdated and thus unpatched for the following vulnerabilities :

- A stack overflow vulnerability exists that could result in arbitrary code execution. (CVE-2014-0498)
- A memory leak vulnerability exists that could be used to aid in buffer overflow attacks by bypassing address space layout randomization (ASLR). (CVE-2014-0499)
- A double free vulnerability exists that could result in arbitrary code execution. (CVE-2014-0502)

Solution

Upgrade to Adobe Flash Player version 12.0.0.70 or later. If 12.x cannot be obtained, 11.7.700.269 has also been patched for these vulnerabilities.

See Also

http://helpx.adobe.com/security/products/flash-player/apsb14-07.html

http://www.zerodayinitiative.com/advisories/ZDI-14-040

Plugin Details

Severity: High

ID: 8807

Family: Web Clients

Published: 2015/07/10

Modified: 2016/01/19

Dependencies: 5158

Nessus ID: 72606, 72607

Risk Information

Risk Factor: High

CVSSv2

Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 8.1

Temporal Score: 7.7

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Patch Publication Date: 2014/02/20

Vulnerability Publication Date: 2014/02/20

Exploitable With

Core Impact

Reference Information

CVE: CVE-2014-0498, CVE-2014-0499, CVE-2014-0502

BID: 65702, 65703, 65704